Hosts from LAN1 should be able to access hosts at LAN2 and vice-versa through GRE tunnel between R1 and R2. ISP doesn’t care what networks are behind R1 and R2 so the only way to establish connection between LAN1 and LAN2 is to use VPN, in this example we use GRE.


GRE setup example topology

R1′s startup-config (part of it)

!

hostname R1
!
interface Tunnel0
description GRE tunell to R2
ip address 192.168.200.1 255.255.255.0
tunnel source 123.123.0.10
tunnel destination 123.123.1.10
!
interface FastEthernet 1/0
ip address 10.0.0.1 255.255.255.0
!
interface Serial1/0
ip address 123.123.0.10 255.255.255.0
serial restart-delay 0
!
ip classless
ip route 0.0.0.0 0.0.0.0 123.123.0.1
ip route 10.1.1.0 255.255.255.0 192.168.200.2
!

R2′s startup-config (part of it)

!

hostname R2
!
interface Tunnel0
description GRE tunnel to R2
ip address 192.168.200.2 255.255.255.0
tunnel source 123.123.1.10
tunnel destination 123.123.0.10
!
interface FastEthernet 1/0
ip address 10.1.1.1 255.255.255.0
!
interface Serial1/0
ip address 123.123.1.10 255.255.255.0
no fair-queue
serial restart-delay 0
!
ip classless
ip route 0.0.0.0 0.0.0.0 123.123.1.1
ip route 10.0.0.0 255.255.255.0 192.168.200.1
!

Results

R2#ping 10.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/17/28 ms

R3#ping 10.0.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/20/44 ms

 

17 Comments

 

  1. February 22, 2010  2:48 am by Rig Reply

    GRE tunnels are awesome. :)

  2. August 17, 2010  10:01 pm by Chris Reply

    Can someone explain how to set up a GRE tunnel to encapsulate Ethernet frames (i.e. send raw l2 traffic across a tunnel)? Thanks.

  3. January 24, 2011  4:42 pm by ledlights nucash.nl fantastico Reply

    Pretty nice post. I just stumbled upon your weblog and wished to say that I've really enjoyed surfing around your blog posts. In any case I will be subscribing to your feed and I hope you write again very soon!

  4. February 21, 2011  10:11 pm by cpanel Reply

    Wow, superb blog layout! How long have you been blogging for? you make blogging look easy. The overall look of your web site is excellent, let alone the content!

  5. April 21, 2011  7:05 pm by soup recipes Reply

    I like what you guys are doing. Such intelligent work and reporting! Keep up the superb works guys. I have incorporated you guys to my blogroll. I think it will improve the value of my web site. :)

  6. April 27, 2011  7:31 pm by Food Deal Reply

    Simply want to say your article is as surprising. The clearness in your post is just cool and i could assume you are an expert on this subject. Fine with your permission allow me to grab your feed to keep updated with forthcoming post. Thanks a million and please keep up the gratifying work.

  7. April 27, 2011  11:25 pm by viagra Reply

    It continually is amazing to me exactly how blog writers such as your self can find the time and the dedication to keep on creating superb blogposts. Your site isgood and one of my personal need to read weblogs. I just needed to thank you.

  8. May 2, 2011  5:20 pm by brazilian wax Reply

    I’ve recently started a site, and the things you provide on this website has been tremendously useful to me. Thanxso much for all of your time & work.

  9. May 7, 2011  9:30 pm by info Reply

    I happen to be commenting to let you know what a remarkable experience our daughter undergone viewing your blog. She came to find so many details, not to mention what it is like to have an excellent giving nature to get most people really easily know selected multifaceted issues. You really surpassed my expectations. I appreciate you for coming up with these productive, dependable, edifying and as well as fun guidance on this topic to Janet.

  10. May 14, 2011  4:34 pm by Lucas Abernathy Reply

    My husband and i have been absolutely thrilled that Louis managed to do his survey by way of the precious recommendations he acquired out of the blog. It's not at all simplistic to simply always be handing out key points that many many others may have been making money from. And we recognize we now have the blog owner to give thanks to for that. These explanations you've made, the simple web site menu, the friendships you can give support to engender - it's most excellent, and it is helping our son in addition to the family understand the issue is exciting, which is certainly really serious. Thank you for all the pieces!

  11. May 15, 2011  6:42 pm by Gersham Sen Reply

    This website online can be a stroll-through for all of the information you needed about this and didn’t know who to ask. Glimpse here, and you’ll definitely discover it.

  12. May 31, 2011  10:27 am by compact sleeping bag Reply

    It's perfect time to produce some plans for the future and it is time to be happy. I've read this blog post and if I could I desire to suggest you few interesting things or advice. Maybe you could write next posts referring to this article. I wish to read even more things about it!

  13. January 22, 2012  12:49 pm by ?????? ??? ????? ???????? ?????? Reply

    ?? ????? ?????? ?? ?? ?????. ???? ???????? ???? ???????. ?????? ??? ? PM.

Leave a reply

 

Your email address will not be published.