OpenLDAP + Samba Domain Controller on Debian or Ubuntu

Historically domain controllers (DCs) were Windows servers responding to security authentication requests (logging in, etc.) within the Windows Server domain. Today Samba project goes beyond emulating Windows shares and can be used as Primary Domain Controller in Windows network. To help people who are under installing/configuring Samba as a DC in their network I published here several links which helped me with this task. First of all, be ready for […]

Read more →

 

Quick copy/paste MySQL Replication Manual

This quick manual tells how to set up database replication in MySQL. Basically it was written for 5.* MySQL versions but is also applicable for 3.23/4.0 ones (btw they are still in use, believe me). As you might already know, replication allows you to create a copy of certain MySQL database from a master server on another server (slave). What is the most important, all updates made to that database […]

Read more →

 

Configure Sudo: no password for certain commands (nopasswd)

Sudo (Super User Do) is Linux console only utility allowing users to execute programs which require root rights without knowing root password. There are lots of topic why sudo rocks on the Web so here you can find a tip how to configure sudo in order to execute certain root right requiring programs without any passwords (it known as sudo nopasswd). There are several ways to configure sudo in Linux […]

Read more →

 

Set Linux Gateway

One can say that it is rather trivial task to set Linux gateway (or in other words to set up/change default gateway in Linux operating system) but I noticed that this question is one of the most popular among linux newbies so I decided to post a quick tip here on Linux Screw. There are two most used ways to set up default gateway using Linux console. Of course modern […]

Read more →

 

Install Firefox 3 in Debian Etch

If you downloaded fresh Firefox 3 installation e.g. from here and tried to install it in Debian Etch, you might notice that latest version of the popular browser requires GTK+ 2.10 while Etch contains only 2.8: We’re sorry, this application requires a version of the GTK+ library that is not installed on your computer. You have GTK+ 2.8.This application requires GTK+ 2.10 or newer.Please upgrade your GTK+ library if you […]

Read more →